Platform Issues - Tasks & Cadences

Incident Report for EverTrue

Resolved

This incident has been resolved.
Posted May 27, 2025 - 14:08 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Please do a hard refresh in your web browser (command+shift+R on Mac, CTRL+F5 on PC) and reach out to genius@evertrue.com if you continue to experience issues.
Posted May 27, 2025 - 10:46 EDT

Investigating

We have identified an issue that is preventing users from accessing the tasks and cadences tabs. We are working to resolve this issue now, if you have any questions please reach out to genius@evertrue.com
Posted May 27, 2025 - 09:39 EDT
This incident affected: EverTrue.